07/04/2018, 1:39 PM
Hello, I've just had a strange behaviour during an
: I tried to update a stack which had no changes and it tried to delete some resource :
$ pulumi update
Previewing update of stack 'prod'
Previewing changes:

   Type  Name  Plan     Info
info: no changes required:
      9 resources unchanged

Do you want to perform this update? yes
Updating stack 'prod'
Performing changes:

     Type                 Name               Status                  Info
 *   pulumi:pulumi:Stack  first-pulumi-prod  done                    
 --  └─ aws:rds:Instance  base_c             **deleting failed**     2 errors
  aws:rds:Instance: base_c
    error: Plan apply failed: deleting urn:pulumi:prod::first-pulumi::aws:rds/instance:Instance::base_c: DB Instance FinalSnapshotIdentifier is required when a final snapshot is required
    error: update failed
info: no changes required:
      9 resources unchanged

Permalink: <>
error: update failed
That's a pretty scary behavior. Any idea what might have happened ?