https://pulumi.com logo
#general
Title
# general
t

tall-librarian-49374

08/24/2018, 1:56 PM
Hi, I'm trying to install azure+pulumi on a new laptop. Getting "Azure CLI Authorization Profile not found" even after successful CLI login. What else should I check?
b

big-piano-35669

08/24/2018, 9:02 PM
This is strange. What does
az account list
show you? Is it possible there isn't a valid Default Subscription, and you need to explicitly choose it via
az account set --subscription=<id>
?
t

tall-librarian-49374

08/24/2018, 9:17 PM
az account list
shows 1 subscription
az account set
hasn't changed anything
The one subscription has isDefault=true
I remember it worked last time I tried on another pc. The login was giving code which I had to paste to browser. Now the browser just pops up and everything works automatically on login side (nice!) but not on pulumi side...
Have they changed something?
b

big-piano-35669

08/26/2018, 8:08 PM
They did change this just recently. But I've been using it successfully. Am guessing from subsequent posts you managed to get this working? If so, curious for future reference, what ended up being the issue?
t

tall-librarian-49374

08/27/2018, 4:43 AM
Nope, that was from another laptop with different versions of cli and pulumi (if that matters)
Hi Joe. I got back to that machine with failing azure login and was able to workaround this by doing
robocopy "$env:userprofile\.azure" "$env:homeshare\.azure"
, found here https://github.com/terraform-providers/terraform-provider-azurerm/issues/417#issuecomment-368952526
4 Views