https://pulumi.com logo
#general
Title
# general
d

dazzling-scientist-80826

10/03/2018, 8:33 PM
i’m seeing some weird behavior with route 53 creating a TXT record on an apex domain. non-apex domain txt records seem to work fine, but when i create an apex record, like for SPF or similar, the creation succeeds, i get a valid resource id, but the domain doesn’t appear in route 53 & doesn’t get returned when i
dig TXT
the server
w

white-balloon-205

10/03/2018, 9:34 PM
That is surprising. When you say you got a valid resource ID - do you mean you got back an ARN or equivalent? If you use
aws
CLI to query for that - does it not exist?
d

dazzling-scientist-80826

10/04/2018, 5:18 PM
sooo i just went to answer this question for you, but i’m not able to reproduce this problem… on my test domain… even tho it was reproducing reliably a few times yesterday on my main domain - really confusing. let me do a little more investigation
ok - soooo this works totally fine on my test domain - same pulumi script, but here’s what happens on my main domain:
the resource name is just HOSTEDZONEID_domainname_TXT
so removing that resource from the pulumi script & then running update causes the resource to be created
but if i try to recreate it
on both test & real domains, it reports success
it’s shown in
aws route53 list-resource-record-sets
for both
BUT for the test domain, it also shows up in the aws console
for the real domain, it doesn’t!
meanwhile, for the test domain,
dig
on the nameserver produces the right record
but on the real domain, it does not
i can manually add the record in the aws console & then it shows up & dig reports the right result
aws route53 list-resource-record-sets
does not show a duplicate record
seems like something is funky on the aws side … just for my main domain ¯\_(ツ)_/¯
…. and just tried it one more time and it worked correctly
my least favorite kind of bug 😕
anyway, this is not really blocking/hurting me in any way now - but it was surprising/confusing
i’m paranoid about checking DNS records anyway - so maybe no action necessary other than remember i said this so that later when somebody else has a similar problem a pattern may start to emerge 🙂 sorry for the distraction