https://pulumi.com logo
#general
Title
# general
f

full-dress-10026

10/16/2018, 5:25 PM
What does this error mean?
Copy code
Previewing destroy of stack 'ComputeSoftware/command-processor-prod'
error: could not find plugin for provider 'urn:pulumi:command-processor-prod::command-processor::pulumi:providers:aws::default'
w

white-balloon-205

10/16/2018, 6:13 PM
I have not seen that before - but it suggests that you do not have the AWS provider plugin installed. Have you run
npm install
or equivalent in this directory?
f

full-dress-10026

10/16/2018, 7:10 PM
Yes
Just tried deleting
node_modules
and running
npm install
and still getting the same error.
This is my `package.json`:
Copy code
{
  "name": "command-processor",
  "devDependencies": {
    "@types/node": "latest"
  },
  "dependencies": {
    "@pulumi/pulumi": "0.16.0",
    "@pulumi/aws": "0.16.0",
    "@pulumi/cloud-aws": "0.16.0",
    "@pulumi/cloud": "0.16.0"
  }
}
Running pulumi CLI v0.15.4.
Here's the output of `pulumi plugin ls`:
Copy code
NAME                       KIND         VERSION                    SIZE               INSTALLED          LAST USED         
aws                        resource     0.16.0                     145 MB             n/a                1 hour ago        
aws                        resource     0.15.2-dev-1538764371-g6f70105 145 MB             n/a                2 hours ago       
aws                        resource     0.15.2-dev-1538687869-ge256ca2 145 MB             n/a                2 hours ago       
aws                        resource     0.15.2-dev-1537910355-g327c12d 144 MB             n/a                2 hours ago       
aws                        resource     0.15.1                     144 MB             n/a                2 hours ago       

TOTAL plugin cache size: 722 MB
So it appears to have the AWS plugin installed.
Ran
pulumi plugin rm --all
then deleted
node_modules
then
npm install
and still getting the error.
The only plugin listed in
pulumi plugin ls
is aws 0.16.0.
w

white-balloon-205

10/16/2018, 7:49 PM
Hmm - this sounds like a bug - we’ll take a look and get back to you.
f

full-dress-10026

10/16/2018, 8:14 PM
Ok thanks.
b

bitter-oil-46081

10/16/2018, 9:50 PM
Hi @full-dress-10026, trying to reproduce this myself now and haven't had much luck yet. I tried the following: Deploying a small aws application using the 0.15.4 CLI and 0.15.1 version of the AWS provider and then updated my package.json file to use the 0.16.0 versions of packages, yarn installed, and then ran update again. Didn't see what you're seeing here. Interested in what the plugins section of your checkpoint looks like (
pulumi stack export
will dump it). Also, there should be a resource in the resouces section that is named
urn:pulumi:command-processor-prod::command-processor::pulumi:providers:aws::default
and it would be interesting to know what the properties of that resource are.
f

full-dress-10026

10/16/2018, 9:59 PM
Looking at the file under the
["deployment" "manifest" "plugins"]
JSON path, I see some directory paths that are related to CircleCI. I use this stack with both locally and with CI.
b

bitter-oil-46081

10/16/2018, 11:01 PM
https://github.com/pulumi/pulumi/issues/2067 gives an explanation of the issue. I think the common way to hit this issue is the following: 1. Have a dependency on `"@pulumi/aws": "dev"`` and then do a deployment via CI. 2. Change the version of the
@pulumi/aws
to an older one and then submit the next update via CI.
👍 1