Hi all, does that type of error speaks to someone ...
# general
Hi all, does that type of error speaks to someone ?
Copy code
* creating urn:pulumi:REDACTED::REDACTED::REDACTED:Cluster$gcp:container/cluster:Cluster::REDACTED: Invalid address to set: []string{"cluster_autoscaling"}
It just happened to appear today while this is the gazillian time I destroy and recreate a cluster
After digging up, it appears this is an optional beta option of the terraform provider : https://www.terraform.io/docs/providers/google/r/container_cluster.html#cluster_autoscaling But it is not referenced in
. I noticed
bumped to version
today, so I tried to downgrade to
but same error.
@white-balloon-205 @echoing-match-29901 needs some help since I am stuck and can’t deploy my clusters anymore… I’m positive I did not change the way my clusters are provisionned with pulumi (I’ve created a few this morning without any issue)
weird thing is, despite the error, the cluster is created and healthy. The error seems to only crash the deployment and i’m unable to proceed further with pulumi.
@faint-motherboard-95438 can you post (or DM if not) the contents of package.json and package.json.lock?
@faint-motherboard-95438 This is an interesting one for sure - it would also be useful to get the program text for the cluster resource
@faint-motherboard-95438 Can you try
pulumi plugin rm resource gcp 0.16.4
and see if that solves things for you?
(while still using the
version of the NPM package)
That will ensure we don't accidentally pick up the newer resource provider plugin even when you are using the
version. We're looking into why this problem occurs in the first place with the latest GCP provider.
@white-balloon-205 thanks, that was it.
I already got a problem like this once, because of the link between your npm packages and your cli. I think you should add a better notice when upgrading on how to rollback if something is wrong afterward. Like
which explicitly tells you the command to use to rollback the update (I actually downgraded the last update of
components while searching where the error was coming from) Since your cli is updated with
(or whatever) and the message saying the npm package installs a plugin is barely noticeable, it was really hard to think the problem was here after having downgraded
. You should force update the plugin whatever the version of the packages npm installs.
Yes - we need to make sure the plugin versions match the package versions. Today this doesn’t quite happen, which is normally not a problem, but can be when there are breaking changes in the plugin. We’re still investigating why there was a breaking change in the underlying GCP Terraform provider plugin here - but separately if we were precisely versioning the plugin with the npm package this would not have been a problem for you when you downgraded. That’s something we intend to fix.
Yep, because that’s really misleading and hard to diagnose. As a rule of thumb, always fix the version, there’s no problem until there’s one ;)
Thanks for your quick help !