https://pulumi.com logo
#general
Title
# general
i

incalculable-angle-91273

01/16/2019, 12:44 AM
hello, I just posted something to golang. I think something in my config is messed up. I tried deploying the sample s3 go app with pulumi here:
Copy code
package main

import (
	"<http://github.com/pulumi/pulumi-aws/sdk/go/aws/s3|github.com/pulumi/pulumi-aws/sdk/go/aws/s3>"
	"<http://github.com/pulumi/pulumi/sdk/go/pulumi|github.com/pulumi/pulumi/sdk/go/pulumi>"
)

func main() {
	pulumi.Run(func(ctx *pulumi.Context) error {
		// Create an AWS resource (S3 Bucket)
		bucket, err := s3.NewBucket(ctx, "my-bucket", nil)
		if err != nil {
			return err
		}

		// Export the DNS name of the bucket
		ctx.Export("bucketName", bucket.BucketDomainName())
		return nil
	})
}
but when I run
pulumi stack
i get this without any outputs:
Copy code
▶ pulumi stack
Current stack is MINDBODY-Platform/bb8-richard-laub:
    Owner: MINDBODY-Platform
    Last updated: 3 minutes ago (2019-01-15 16:40:04.79614 -0800 PST)
    Pulumi version: v0.16.10
    Plugin go [language] version: 0.16.10
    Plugin aws [resource] version: 0.16.5

Current stack resources (3):
    TYPE                  NAME
    pulumi:pulumi:Stack   bb8-bb8-richard-laub
    pulumi:providers:aws  default
    aws:s3/bucket:Bucket  my-bucket

Current stack outputs (0):
    No output values currently in this stack

More information at: <https://app.pulumi.com/MINDBODY-Platform/bb8-richard-laub>

Use `pulumi stack select` to change stack; `pulumi stack ls` lists known ones
What is causing my outputs not to show?