https://pulumi.com logo
#general
Title
# general
g

gray-city-50684

03/25/2019, 6:32 PM
I’m trying to use the Cloudflare provider, and would like to configure the provider instance myself and passing it to the resources with the opts.provider field. However just having the following code const cfProvider = new cloudflare.Provider(“CF-Provider”, { email: “no@no.to”, token: “abrakadabra” } ); causes the following error when doing “pulumi up” (there are no Cloudflare resources in my code yet): error: Missing required configuration variable ‘cloudflare:email’ please set a value using the command
pulumi config set cloudflare:email <value>
error: an unhandled error occurred: Program exited with non-zero exit code: 1
w

white-balloon-205

03/25/2019, 6:36 PM
I assume it works fine if you use the default provider instead of
new cloudflare.Provider
? If so, I suspect I know what the problem might be (which unfortunately is pretty common for new providers because there's some manual work needed - and is tracked in https://github.com/pulumi/pulumi-terraform/issues/292). I'll open a bug on this specifically for cloudflare so we can fix. In the meantime, I suspect setting a dummy
pulumi config set cloudflare:email <mailto:does@notexist.com|does@notexist.com>
will unblock. Let me know if now.
g

gray-city-50684

03/25/2019, 6:41 PM
thx, if I set cloudflare:email and cloudflare:token with “pulumi config set” the “pulumi up” is successful
👍 1