https://pulumi.com logo
#general
Title
# general
b

big-potato-91793

03/29/2019, 8:29 PM
Hey i got this error trying to do a
pulumi up
, I got the
You must specify exactly two subnets because you've set zone count to two.
trying to deploy a AWS Elasticsearch service
w

white-balloon-205

03/29/2019, 8:36 PM
Are you passing two subnets?
b

big-potato-91793

03/29/2019, 8:38 PM
Copy code
vpcOptions          : {
            securityGroupIds: [
                [0]: "sg-0986fd74"
                [1]: "sg-723a380a"
            ]
            subnetIds       : [
                [0]: "subnet-95c904cd"
                [1]: "subnet-a4f0098e"
                [2]: "subnet-457ed533"
            ]
        }
w

white-balloon-205

03/29/2019, 9:07 PM
Looks like support for ES deployments to 3 AZs was only added recently - https://github.com/aws/aws-sdk-go/blob/master/CHANGELOG.md#release-v11630-2019-02-07 - and that this is not yet available in the Pulumi provider or the upstream Terraform AWS provider (https://github.com/terraform-providers/terraform-provider-aws/issues/7504).
b

big-potato-91793

03/29/2019, 9:20 PM
But i only get 2 instances. So i used only 2 subnets
w

white-balloon-205

03/29/2019, 10:11 PM
I see three subnets in the code snippet above. Do you get the same error if you remove one of the subnets?
b

big-potato-91793

03/30/2019, 12:03 PM
yeah, it works 🙂
The only thing, is when i created a vpc es + domainPolicy + route 53 i’m still enabled to acces my es 😞
Found the problem.
w

white-balloon-205

04/01/2019, 3:50 PM
Great - was it a Pulumi issue in the end - or something with AWS ES?
b

big-potato-91793

04/01/2019, 4:40 PM
was something with what are account was setup….
👍 1
2 Views