I have a block that create an NS record based on a...
# general
I have a block that create an NS record based on another record:
Copy code
new azure.dns.NsRecord(`${args.ZoneArgs.name}`, {
        name: args.ZoneArgs.name,
        resourceGroupName: parentZone.resourceGroupName,
        zoneName: parentZone.name,
        record: pulumi.output(dnsZone.nameServers).apply(x => x.map(y => ({ nsdname: y }))),
        ttl: args.Ttl
but it always wants to update the resource - I suspect azure is shuffling the records order around to load balance the servers in some way, it's only ever the order that changes. Is the best workaround just to sort them?
Is this with recent versions of the Pulumi CLI and azure package? I would expect this to not be an issue. If you are seeing this with recent versions, please do open an issue so we can look into it more deeply.
yeah still the same - i reported it here https://github.com/pulumi/pulumi-azure/issues/243 i've just tried adding ignoreChanges: ["records"] and i think that might have done the trick but too early to say
oh i guess that issue doesn't fully describe the issue but i've been workong on the assumption that they're related!
https://github.com/pulumi/pulumi-azure/issues/359 filed a separate issue specifically about this