https://pulumi.com logo
#general
Title
# general
r

rapid-eye-32575

07/18/2019, 7:48 AM
It seems that Pulumi wants to replace all k8s resources because the provider of the underlying EKS cluster is marked to be replaced as well. The EKS cluster was created via
Copy code
new eks.Cluster(stackName, {
  instanceType: "t2.medium",
  desiredCapacity: 2,
  minSize: 2,
  maxSize: 4,
  nodeRootVolumeSize: 60
});
and that code hasn't changed in months. Does anybody have an idea what might be going on and how to fix this? The preview just states that the provider will be replaced but no diff is provided.
To clarify that: the diff for the provider is actually showing something: It's showing that the previous value of the `kubeconfig`is now possibly changing i.e. it says it will be replaced with
output<string>
b

better-rainbow-14549

07/18/2019, 9:08 AM
i get this quite often with the azure AKS changes
pulumi preview --diff > diff
and see what the changes are
i've manually patched my state file a few times in the last few months it works ok
with AKS it was a matter of changing agentProfile: {} to agentProfiles: [{}]
kubeConfig and stuff becoming output<string> is usually a side effect of the thing causing the change not the actual cause IME
output<string> in the diff means it doesnt know what the value will be until it starts
another cause i had was that the service principal metadata that owns a cluster changed
r

rapid-eye-32575

07/18/2019, 9:14 AM
Thanks, @better-rainbow-14549. I don't know though what to patch in the state file regarding the EKS cluster because every output the
kubeconfig
property depends on is unchanged seemingly. I tried to set different values and in the exported stack and re-importing it, but the behaviour stays the same 😞
b

better-rainbow-14549

07/18/2019, 9:18 AM
:S
g

glamorous-printer-66548

07/18/2019, 10:30 AM
@rapid-eye-32575 I had a (possibly) similar error yesterday with pulumi attempting to replace a resource that has not really changed and the diff being not very useful. With the help of @white-balloon-205 I was able to see what has changed by installing
curl -L <https://get.pulumi.com/> | bash -s -- --version 0.17.23
. This is a very new pulumi version that shows more complete diffs.
r

rapid-eye-32575

07/18/2019, 10:35 AM
Thanks for the advice @glamorous-printer-66548. I just tried it with
0.17.23
and the output is different for some unrelated CloudFront resources. However, the preview details look the same regarding the Kubernetes provider.