https://pulumi.com logo
#general
Title
# general
g

glamorous-waitress-51149

08/07/2019, 9:20 AM
Just wondering if there’s anything we can do to push this issue forwards? https://forums.aws.amazon.com/thread.jspa?threadID=307382
One thing I have noticed is that pulumi reports this when it does fail
~  aws:rds:Cluster default updating [diff: -scalingConfiguration~engineVersion]
so for some reason something thinks that has changed even though it hasn’t
b

broad-dog-22463

08/07/2019, 9:21 AM
I wil ltry and recreate this and see
g

glamorous-waitress-51149

08/07/2019, 9:28 AM
i can give you the code if you like
and i just realised its in the forum post
need more coffee
not sure if how we create the dbsubnet and security group will effect it
b

broad-dog-22463

08/07/2019, 10:10 AM
that won't
this is around versions of instances etc
@glamorous-waitress-51149 testing this now
Copy code
4637 ◯ : pulumi up
Previewing update (dev):

     Type                                    Name                 Plan
 +   pulumi:pulumi:Stack                     aws-rds-cluster-dev  create
 +   ├─ awsx:x:ec2:Vpc                       my-vpc               create
 +   │  ├─ awsx:x:ec2:InternetGateway        my-vpc               create
 +   │  │  └─ aws:ec2:InternetGateway        my-vpc               create
 +   │  ├─ awsx:x:ec2:Subnet                 my-vpc-private-1     create
 +   │  │  ├─ aws:ec2:RouteTable             my-vpc-private-1     create
 +   │  │  ├─ aws:ec2:Subnet                 my-vpc-private-1     create
 +   │  │  └─ aws:ec2:RouteTableAssociation  my-vpc-private-1     create
 +   │  ├─ awsx:x:ec2:Subnet                 my-vpc-private-0     create
 +   │  │  ├─ aws:ec2:RouteTable             my-vpc-private-0     create
 +   │  │  ├─ aws:ec2:Subnet                 my-vpc-private-0     create
 +   │  │  └─ aws:ec2:RouteTableAssociation  my-vpc-private-0     create
 +   │  └─ aws:ec2:Vpc                       my-vpc               create
 +   ├─ aws:rds:SubnetGroup                  my-subnet-group      create
 +   └─ aws:rds:Cluster                      my-cluster           create
g

glamorous-waitress-51149

08/07/2019, 1:54 PM
👍
what we tend to find is it might work, leave it 5-10mins, run it again and it says it has to change the rds engine version and then fails
run it again straight away and it deploys fine
b

broad-dog-22463

08/07/2019, 1:59 PM
ah interesting...
will try and recreate it!
Well there we go 🙂
Copy code
pulumi:pulumi:Stack: (same)
    [urn=urn:pulumi:dev::aws-rds-cluster::pulumi:pulumi:Stack::aws-rds-cluster-dev]
    ~ aws:rds/cluster:Cluster: (update)
        [id=tf-20190807140251996100000001]
        [urn=urn:pulumi:dev::aws-rds-cluster::aws:rds/cluster:Cluster::my-cluster]
        [provider=urn:pulumi:dev::aws-rds-cluster::pulumi:providers:aws::default_0_18_26::ef4d6418-a8a1-4af9-8c0b-0a03933ce3e2]
      ~ engineVersion       : "5.6.10a" => "5.6"
      - scalingConfiguration: {
          - autoPause            : true
          - maxCapacity          : 16
          - minCapacity          : 1
          - secondsUntilAutoPause: 300
          - timeoutAction        : "RollbackCapacityChange"
        }
and that's the error you see
Copy code
error: Plan apply failed: 1 error occurred:
    	* updating urn:pulumi:dev::aws-rds-cluster::aws:rds/cluster:Cluster::my-cluster: Failed to modify RDS Cluster (tf-20190807140251996100000001): InvalidParameterCombination: You currently can't modify EngineVersion with Aurora Serverless.
    	status code: 400, request id: ac022620-d538-4391-9c97-304c5f9395ab
so your code isn't quite correct @glamorous-waitress-51149
g

glamorous-waitress-51149

08/07/2019, 2:10 PM
lies!
😉
b

broad-dog-22463

08/07/2019, 2:11 PM
the engine version must be
5.6.10a
🙂
that's even what the AWS console tells me
that will fix you up and you can close https://forums.aws.amazon.com/thread.jspa?threadID=307382 that 🙂
g

glamorous-waitress-51149

08/07/2019, 2:13 PM
awesome, bit of a minefiled this aint it 🙂
will give it a go
appreciate you looking into it as our deployments were constantly failing
b

broad-dog-22463

08/07/2019, 2:13 PM
yeah RDS Engine versions are painful for sure
nps!
Sorry the error message wasn't more useful there
shame it was from the AWS API
g

glamorous-waitress-51149

08/07/2019, 2:16 PM
cool, thanks a million
b

broad-dog-22463

08/07/2019, 2:20 PM
nps! Glad we got it sorted
also "thanks a million" - you've been working with @fresh-summer-65887 too long 😉 #IrishSaying haha
g

glamorous-waitress-51149

08/07/2019, 2:24 PM
damn it, i might make a snuff video and make him watch me eat a potato
@broad-dog-22463 just updated our code to use that version
same error
Copy code
2019-08-07T16:38:03.7679262Z Diagnostics:
2019-08-07T16:38:03.7680395Z   pulumi:pulumi:Stack (profiles-sandbox):
2019-08-07T16:38:03.7680551Z     error: update failed
2019-08-07T16:38:03.7680664Z  
2019-08-07T16:38:03.7680752Z   aws:rds:Cluster (default):
2019-08-07T16:38:03.7680874Z     error: Plan apply failed: 1 error occurred:
2019-08-07T16:38:03.7681528Z     	* updating urn:pulumi:sandbox::profiles::aws:rds/cluster:Cluster::default: Failed to modify RDS Cluster (profiles-mysql-aurora): InvalidParameterCombination: You currently can't modify EngineVersion with Aurora Serverless.
2019-08-07T16:38:03.7682058Z     	status code: 400, request id: dc00b0c7-1e6d-4b74-b747-7758d73b7387
2019-08-07T16:38:03.7682186Z
Copy code
const cluster = new aws.rds.Cluster("default", {
    backupRetentionPeriod: 5,
    clusterIdentifier: prefix + "mysql-aurora",
    engine: "aurora",
    engineVersion: "5.6.10a",
    databaseName: "mydb",
    masterPassword: databasePassword,
    masterUsername: "foo",
    preferredBackupWindow: "07:00-09:00",
    skipFinalSnapshot: true,
    engineMode: "serverless",
    dbSubnetGroupName: dbSubnet.name,
    vpcSecurityGroupIds: [sg.id]
});
b

broad-dog-22463

08/07/2019, 4:41 PM
Can you run Pulumi refresh and grab any details it’s going to refresh?
Without agreeing the changes I mean
g

glamorous-waitress-51149

08/07/2019, 4:51 PM
calling that i get
Copy code
error: Preview failed: error validating provider credentials: error calling sts:GetCallerIdentity: NoCredentialProviders: no valid providers in chain. Deprecated.
        For verbose messaging see aws.Config.CredentialsChainVerboseErrors
seem to get around that
no errors
no info about rds
signing off for now
@broad-dog-22463 morning 🙂
b

broad-dog-22463

08/08/2019, 7:43 AM
morning
so that didn't work for you?
g

glamorous-waitress-51149

08/08/2019, 7:45 AM
refresh didnt seem to show any errors for example
b

broad-dog-22463

08/08/2019, 7:49 AM
ok, let ne check it and see
give me a little bit - just running some local builds setting up some testing
g

glamorous-waitress-51149

08/08/2019, 7:50 AM
no worries, thanks
b

broad-dog-22463

08/09/2019, 12:28 PM
@glamorous-waitress-51149 so after some investigation, the following code works perfectly for me
Copy code
const cluster = new aws.rds.Cluster("default", {
    backupRetentionPeriod: 5,
    clusterIdentifier: "mysql-aurora-stack72",
    engine: "aurora",
    engineVersion: "5.6.10a",
    databaseName: "mydb",
    masterPassword: "MySecr4tPassword123!",
    masterUsername: "foo",
    preferredBackupWindow: "07:00-09:00",
    skipFinalSnapshot: true,
    engineMode: "serverless",
    dbSubnetGroupName: subnetGroup.name,
});
I was able to initially deploy with 5.6
pulumi was showing a diff on refresh, and I said yes to the refresh then I was able to change my index.ts to reflect 5.6.10a
g

glamorous-waitress-51149

08/09/2019, 12:45 PM
but its no different to mine 🙂
or am i missing something?
b

broad-dog-22463

08/09/2019, 1:29 PM
can you run
pulumi stack export
and grab the RDS portion and DM me it?
cheers!
g

glamorous-waitress-51149

08/09/2019, 1:58 PM
saying that, i just checked our deployments and we’ve had 5 today and they all succeeded so we might be in a good place 🙂
b

broad-dog-22463

08/09/2019, 2:00 PM
ah brilliant!
so maybe it's all ok?
g

glamorous-waitress-51149

08/09/2019, 2:27 PM
maybe 😉
i’ll keep an eye on it and ping you if comes crashing down 🙂
thanks for looking into this all, appreciate it!
b

broad-dog-22463

08/09/2019, 2:56 PM
👍 no worries at all
f

fresh-summer-65887

08/13/2019, 10:26 AM
Ty @broad-dog-22463
2 Views