https://pulumi.com logo
#general
Title
# general
c

careful-baker-18386

09/09/2019, 8:01 PM
Checked the FAQs, troubleshooting, docs and searched errors on this slack channel for the following issue: Running through the quick start aws-typescript and the first time I run
pulumi up
i get the following in my debug output:
Copy code
Diagnostics:
  aws:s3:Bucket (my-bucket):
    error: error validating provider credentials: error calling sts:GetCallerIdentity: NoCredentialProviders: no valid providers in chain. Deprecated.
        For verbose messaging see aws.Config.CredentialsChainVerboseErrors
 
  pulumi:pulumi:Stack (pulu-dev):
    debug: Registering resource: t=pulumi:pulumi:Stack, name=pulu-dev, custom=false
    debug: RegisterResource RPC prepared: t=pulumi:pulumi:Stack, name=pulu-dev
    debug: RegisterResource RPC finished: resource:pulu-dev[pulumi:pulumi:Stack]; err: null, resp: urn:pulumi:dev::pulu::pulumi:pulumi:Stack::pulu-dev,,,,
    debug: Running program '/Users/leif/Sites/pulu' in pwd '/Users/leif/Sites/pulu' w/ args: 
    debug: Registering resource: t=aws:s3/bucket:Bucket, name=my-bucket, custom=true
    debug: RegisterResource RPC prepared: t=aws:s3/bucket:Bucket, name=my-bucket
    debug: Setting AWS metadata API timeout to 100ms
    debug: Ignoring AWS metadata API endpoint at default location as it doesn't return any instance-id
    debug: No assume_role block read from configuration
    debug: Building AWS auth structure
    debug: Setting AWS metadata API timeout to 100ms
    debug: Ignoring AWS metadata API endpoint at default location as it doesn't return any instance-id
    debug: AWS Auth using Profile: "carpedalan"
    debug: Trying to get account information via sts:GetCallerIdentity
g

gentle-diamond-70147

09/09/2019, 8:02 PM
How have you provided your AWS credentials?
c

careful-baker-18386

09/09/2019, 8:05 PM
yea, i have run both
pulumi config set aws:profile the-profile
and
AWS_PROFILE=the-profile pulumi up
and neither work
i have
aws-cli
installed with an
~/.aws/credentials
file with several profiles fwiw
oh interesting. it defaulted to use the value in
Pulumi.dev.yml
, so this was pointing to the wrong profile that didn’t have permissions to create a bucket.
c

clever-sunset-76585

09/09/2019, 10:20 PM
it defaulted to use the value in
Pulumi.dev.yml
, so this was pointing to the wrong profile that didn’t have permissions to create a bucket.
It should shouldn’t “default” to a specific stack as far as I know. It might be that that was the last stack you used? I believe if you run
pulumi stack select <stack name>
it should change the active stack. You can see the active stack by running
pulumi stack ls
in the directory where your stack config files are, and you should see a
*
next to the currently selected one. EDIT: Sorry. I had a typo in my message above. I actually meant to type, it shouldn’t default to a specific stack.
Were you passing the
-s
flag to your
pulumi up
command previously? If so, that wouldn’t change the active stack, just runs the command with that stack’s config, as though it were the active stack.
c

careful-baker-18386

09/09/2019, 10:53 PM
i did not use the
-s
flag, this was my first attempt using the getting started workflow.
g

gentle-diamond-70147

09/09/2019, 11:11 PM
What was set in your
Pulumi.dev.yaml
?
c

careful-baker-18386

09/10/2019, 6:42 PM
the wrong AWS profile that did not have the correct permissions to execute