https://pulumi.com logo
w

worried-city-86458

10/10/2019, 8:55 PM
Copy code
pulumi:pulumi:Stack (k8s-infra-dev):
    Error: The gRPC binary module was not installed. This may be fixed by running "npm rebuild"
    Original error: Cannot find module '/workspaces/devops-gemini-pulumi/k8s-infra/node_modules/grpc/src/node/extension_binary/node-v72-linux-x64-glibc/grpc_node.node'
    Require stack:
    - /workspaces/devops-gemini-pulumi/k8s-infra/node_modules/grpc/src/grpc_extension.js
    - /workspaces/devops-gemini-pulumi/k8s-infra/node_modules/grpc/src/client_interceptors.js
    - /workspaces/devops-gemini-pulumi/k8s-infra/node_modules/grpc/src/client.js
    - /workspaces/devops-gemini-pulumi/k8s-infra/node_modules/grpc/index.js
    - /workspaces/devops-gemini-pulumi/k8s-infra/node_modules/@pulumi/pulumi/runtime/settings.js
    - /workspaces/devops-gemini-pulumi/k8s-infra/node_modules/@pulumi/pulumi/log/index.js
    - /workspaces/devops-gemini-pulumi/k8s-infra/node_modules/@pulumi/pulumi/cmd/run/run.js
    - /workspaces/devops-gemini-pulumi/k8s-infra/node_modules/@pulumi/pulumi/cmd/run/index.js
        at Object.<anonymous> (/workspaces/devops-gemini-pulumi/k8s-infra/node_modules/grpc/src/grpc_extension.js:43:17)
        at Module._compile (internal/modules/cjs/loader.js:936:30)
        at Object.Module._extensions..js (internal/modules/cjs/loader.js:947:10)
        at Module.load (internal/modules/cjs/loader.js:790:32)
        at Function.Module._load (internal/modules/cjs/loader.js:703:12)
        at Module.require (internal/modules/cjs/loader.js:830:19)
        at require (internal/modules/cjs/helpers.js:68:18)
        at Object.<anonymous> (/workspaces/devops-gemini-pulumi/k8s-infra/node_modules/grpc/src/client_interceptors.js:144:12)
        at Module._compile (internal/modules/cjs/loader.js:936:30)
        at Object.Module._extensions..js (internal/modules/cjs/loader.js:947:10)
 
    error: an unhandled error occurred: Program exited with non-zero exit code: 1
I've just updated to Pulumi 1.3.1 and Pulumi Kubernetes 1.2.2 and now get the above I'm running it in Ubuntu 18.04 via VS Code remote container
I guess I'll have to add some requirements to my docker image so wondering what changed...
Never mind. I deleted my
node_modules
directory, re-ran
yarn install
and all good now.
PS. preview and update perf with Pulumi Kubernetes 1.2.2 is really good now! woohoo
2 Views