https://pulumi.com logo
#general
Title
# general
n

numerous-iron-8383

10/16/2019, 9:15 AM
Hello, I am new to pulumi, previously I worked with terraform a lot. Recently for one project I decided to use pulumi instead of terraform. I wrote initial setup of AWS vpc/ecs/fargate/lambda/codedeploy/etc/s3 stack, however
pulumi up
crashes... It creates all resources it should, then hangs and after few minutes I get
JavaScript heap out of memory
error. I tested it with Node.js 10/12 and with Pulumi 1.1.0 / 1.3.1 and latest HEAD - every time the same problem. I saw someone had similar issue https://github.com/pulumi/pulumi/issues/3279 but with StackReference which I don't use at all. I believe my stack is not anything special, it's standard AWS stack I guess. Has anyone had similar problems with Pulumi? Are you stacks working as expected (in production?) - if yes can anyone share which pulumi / node version you are using for stack provisioning? Thanks
b

best-xylophone-83824

10/16/2019, 9:20 AM
I use official pulumi image
👍 1
n

numerous-iron-8383

10/16/2019, 12:40 PM
For me it crashes also in official docker image 😞.
3 Views