https://pulumi.com logo
#general
Title
# general
e

early-musician-41645

10/29/2019, 6:35 PM
I'm trying to run this code:
Copy code
const tentacleVpcId = tentacleConfig.require("vpcId");
console.log("VPC-ID: "+tentacleVpcId);

export const tentacleVpc = awsx.ec2.Vpc.fromExistingIds("tentacle-vpc", {
  vpcId: tentacleVpcId,
});
However I get this error:
Copy code
Error: invocation of aws:ec2/getVpc:getVpc returned an error: invoking aws:ec2/getVpc:getVpc: no matching VPC found
I've checked and rechecked everything (account, credentials, resource ids, config, stack) and still no luck. I ran a
pulumi preview --debug
and I see that there's this output:
Copy code
Reading AWS VPC: {
  Filters: [{
    Name: "isDefault",
    Values: ["true"]
  }]
}
The VPC is not the default one. It's one of many VPCs. How can I make pulumi get a non-default VPC?
g

gentle-diamond-70147

10/29/2019, 7:00 PM
I don't see this same
Reading AWS VPC ...
output when I do
pulumi preview --debug --logtostderr
and I am able to retrieve a non-default VPC using
awsx.ec2.Vpc.fromExistingIds
. Are you on an older awsx version perhaps?
e

early-musician-41645

10/29/2019, 7:03 PM
I'm on 0.18.8. I'll try upgrading
tried upgrading and now seeing this:
Copy code
error: Running program '/home/tsi/eshamay/git/cs/octopus-deploy/pulumi/octopus-tentacles' failed with an unhandled exception:
    /home/tsi/eshamay/git/cs/octopus-deploy/pulumi/octopus-tentacles/node_modules/@pulumi/awsx/ec2/cidr.js:50
            const ipAddressesInBlock = 2 ** trailing1Bits;
                                          ^

    SyntaxError: Unexpected token *
tried downgrading to each version and still seeing that syntax error