https://pulumi.com logo
#general
Title
# general
e

elegant-flag-85647

11/22/2019, 4:20 PM
When importing an app service plan resource on azure, I get the following warning:
Copy code
=   └─ azure:appservice:Plan  dev                             import     [diff: +location,reserved,sku~kind,name]; 1 warn
Diagnostics:
  azure:appservice:Plan (dev):
    warning: inputs to import do not match the existing resource; importing this resource will fail
Is there a way to diff the current and preview state of apps? The details section gives me some info but it doesn’t present a diff (I’m guessing it might be due to casing Linux vs linux causing pulumi to think that the details do not match.) I have tried running with
-v=3
but did not help that much.
I have tried running
pulumi up -d
which yields the json retrieved from azure. I have changed the kind to "linux" and location to "East US" as opposed to using the enums, but it didn't help that much.
Ah, found it, it is the same issue as in terraform. App Service Plan was named serverFarm before, but to import it the serverFarm string in the import id has to be
serverfarm
all lowercase. See https://github.com/terraform-providers/terraform-provider-azurerm/issues/1507
g

gentle-diamond-70147

11/22/2019, 6:52 PM
Interesting... thanks for posting the solution you found!