https://pulumi.com logo
#general
Title
# general
c

chilly-photographer-60932

11/30/2019, 12:12 AM
Copy code
pulumi:pulumi:Stack (aws-arcus-kitchensink-naveen-srinivasan):
    error: an unhandled error occurred: Program exited with non-zero exit code: 1
 
    The Pulumi runtime detected that 255 promises were still active
    at the time that the process exited. There are a few ways that this can occur:
      * Not using `await` or `.then` on a Promise returned from a Pulumi API
      * Introducing a cyclic dependency between two Pulumi Resources
      * A bug in the Pulumi Runtime
    Leaving promises active is probably not what you want. If you are unsure about
    why you are seeing this message, re-run your program with the `PULUMI_DEBUG_PROMISE_LEAKS`
    environment variable. The Pulumi runtime will then print out additional
    debug information about the leaked promises.
 
Permalink: <https://app.pulumi.com/MINDBODY-Platform/aws-arcus-kitchensink/naveen-srinivasan/previews/2daf38a1-f35b-4223-ba19-ca871a9f5ebd>
Running into this error ☝️ . What could be wrong?
w

white-balloon-205

11/30/2019, 5:53 PM
Have you tried rerunning with the env var set as suggested? This normally means some promise do not have anything waiting on it. It could be an issue in the Pulumi runtime, but I have not seen any issues related to this recently - so my guess is it’s something in your code. The additional details you get if you enable that env var may help pinpoint the problem.
c

chilly-photographer-60932

12/02/2019, 4:13 PM
Here is the leaks from the stackoutput any help would be greatly appreciated. I am stuck with this and it is a blocker. Thanks
w

white-balloon-205

12/02/2019, 5:07 PM
I see this - that seems to be the root cause. Did you make any recent changes that might have caused that?
Copy code
Promise leak detected:
    CONTEXT: transferIsSecret(resource:monitoring-nodes[aws:cloudformation/stack:Stack], tags, Calling [toString] on an [Output<T>] is not supported.
    To get the value of an Output<T> as an Output<string> consider either:
    1: o.apply(v => `prefix${v}suffix`)
    2: pulumi.interpolate `prefix${v}suffix`
    See <https://pulumi.io/help/outputs> for more details.
    This function may throw in a future version of @pulumi/pulumi.)
c

chilly-photographer-60932

12/02/2019, 8:02 PM
No, I haven’t. The funny thing is that it works perfectly fine on other stacks. But when I try and do it on this stack it runs into an issue.
@white-balloon-205 Any other ideas?
w

white-balloon-205

12/03/2019, 1:56 AM
Can you share the snippet of code used to create the resource referenced above ( an aws.cloudformation.Stack named monitoring-nodes?). In particular - what is passed into its tags?
c

chilly-photographer-60932

12/03/2019, 4:30 PM
I removed the cloudformation for monitoring and I still see the issue.
@white-balloon-205 Any update on this?
w

white-balloon-205

12/05/2019, 12:57 AM
cc @lemon-spoon-91807 and @microscopic-florist-22719 as I've been talking to them offline about this. One thing we noticed is the use of some tests running during the deployment. That testing framework may well be part of what's triggering this. Is it possible to temporarily disable the tests from running and see if you still hit this?
c

chilly-photographer-60932

12/05/2019, 2:38 PM
Absolutely!
☝️ sorry I posted in the wrong thread
@white-balloon-205 I am dead in the water because of this. I have been using
dev
stack instead of using my own personal stack which is not acceptable within the org. I would appreciate the help. I have torn down the stack and tried it back multiple times and non of that helps.
m

microscopic-florist-22719

12/06/2019, 6:21 PM
@chilly-photographer-60932 let's take this to DM
c

chilly-photographer-60932

12/06/2019, 6:22 PM
OK. Thanks
l

lemon-spoon-91807

12/06/2019, 6:32 PM
@microscopic-florist-22719 lmk if you need help from me.
👍 1
3 Views