https://pulumi.com logo
#general
Title
# general
a

astonishing-cartoon-37000

12/10/2019, 9:14 PM
This may be something dumb on my end, but I have been debugging this for a little while now and am quite frustrated. If someone has suggestions it would be greatly appreciated. When I run pulumi preview locally in a project everything is dandy. However when I run in CI i'm getting
Copy code
Diagnostics:
  pulumi:pulumi:Stack (xxxxx-staging):
    error: an unhandled error occurred: Program exited with non-zero exit code: -1
I'll thread the verbose logs.
Here is running
pulumi -v=7 --logtostderr preview
in ci
w

white-balloon-205

12/10/2019, 9:22 PM
Curious - what language is this? It seems almost like the language process is dying before it can do anything. It might be that
-v=9
includes more details - though maybe not.
a

astonishing-cartoon-37000

12/10/2019, 9:22 PM
It is typescript
I can run
-v=9
if you think the output would be more helpful. It's a lot of calls for me to wrap my head around 😄
w

white-balloon-205

12/10/2019, 9:30 PM
Yeah - the log just shows that the NodeJS process crashed without doing anything within 100ms of launching. It’s possible more verbose logs could capture something else - but otherwise I’d suggest trying to log something from your NodeJS code as early as possible (ideally before even importing any libraries) to see if you can pin down what is causing the crash.
a

astonishing-cartoon-37000

12/10/2019, 9:30 PM
@white-balloon-205 output for
-v=9
looks identical. I'm going to try and run inside
pulumi/pulumi
docker image we have our own container that is pretty old. where we manually install lots of things. If you have any other ideas lemme know! ty for time
interesting. I'll try an
console.log
in code real quick
w

white-balloon-205

12/10/2019, 9:32 PM
It almost feels like it could be an out of memory issue or something along those lines that is causing a hard crash of the Node process.
a

astonishing-cartoon-37000

12/10/2019, 9:33 PM
what's so interesting to me is we have everything (atleast at a glance) version locked and it has worked before. 🤷 nothing should have changed. Project has been sitting on shelve for a little while
I misspoke too this is simply a javascript project, no typescript
looks like you were correct, even a first line
console.log
before
requires
doesn't log
i'll try the pulumi managed docker image and get back. hopefully it's something dumb about our environment
The Pulumi container worked! no idea what was the issue, but thanks for taking your time to suggest things. I don't like having to update my own image anyway.