https://pulumi.com logo
b

best-waiter-16927

12/25/2019, 11:51 AM
HELP! It seems that changing awsrdsSubnetGroup description (!!!) is causing an awsrdsClusterInstace replacement. This is insane! We tried different pulumi/aws versions: 1.7.0 - 1.14.0 - happens on all of them. Note that in pulumi/aws 1.8.0 there is a change to subnetgroup description so we are currently stuck on 1.7.0 due to this breaking change.
😥 1
b

broad-dog-22463

12/25/2019, 12:57 PM
Hi @best-waiter-16927 Unfortunately, as far as I can tell, changing a description of the subnet group isn’t actually supported by the aws cli or the sdk And this why Pulumi has this limitation https://docs.aws.amazon.com/cli/latest/reference/rds/modify-db-subnet-group.html Can you edit the description in the AWS console? If so then you can use Pulumi refresh to get that change
Also @best-waiter-16927 you can pass ignoreChanges to the CustomResourceOptions to say ignore changes to description Eg (writing on my phone) Const myGroup = new aws.rds.SubnetGroup(“my-group”,{},{ ignoreChanges: [“description”] })
And that will stop the ForceNew
b

best-waiter-16927

12/25/2019, 1:28 PM
@broad-dog-22463 Thanks for your quick reply! Indeed the ignoreChanges worked as expected 💪 Thank you! I would recommend adding a warning in pulumi-aws CHANGELOG on version 1.8.0 since there is a forced change to the default description which can cause this issue: https://github.com/pulumi/pulumi-aws/blob/master/CHANGELOG.md#180-2019-11-07
b

broad-dog-22463

12/25/2019, 1:31 PM
I’m glad that worked - I’ll add an entry to the changelog to use ignoreChanges - sorry that caught you :/
🙏 1
Feel free to let me know if there are any other issues
s

stocky-spoon-28903

12/25/2019, 3:17 PM
Maybe we should back out the description change there
b

broad-dog-22463

12/25/2019, 4:36 PM
@stocky-spoon-28903 it was like 5 releases ago - maybe more :(
11 releases ago actually