https://pulumi.com logo
#general
Title
# general
g

green-morning-1318

03/18/2020, 8:31 PM
Hi y’all! I probably broke something, but I’m not too sure what I broke 🤔
Copy code
$ pulumi --help
error: program failed: missing project name
So when I run any pulumi command, regardless of whether I run the command in a folder with a proper Pulumi config I get the error
missing project name
.
l

limited-rainbow-51650

03/18/2020, 8:32 PM
@green-morning-1318 do you have a
Pulumi.yaml
in your project root? does it have a
name: <project-name>
property defined?
g

green-morning-1318

03/18/2020, 8:32 PM
yup, I do 🙂
name: acmeserverless-payment
aha! found the issue… for some reason it seems my
go get
added a pulumi binary to my bin folder. That binary got executed when I ran pulumi instead of the binary I expected it to be
l

limited-rainbow-51650

03/18/2020, 8:41 PM
That might be something to look into for the Pulumi team. @white-balloon-205 ^
w

white-balloon-205

03/18/2020, 10:05 PM
Yes - this is technically "by design", but can be surprising (I've gotten bitten by this myself). We should at the very least clearly document this. But we may also want to require being a little more explicit if you want to use a pre-built binary (setting an option in the
Pulumi.yaml
) instead of just something with the right name happening to be on the path. cc @lemon-agent-27707
g

green-morning-1318

03/18/2020, 10:12 PM
It does make me feel a little better I’m not the only one 😅
2 Views