https://pulumi.com logo
#general
Title
# general
b

breezy-gold-44713

03/30/2020, 11:54 PM
I’m getting a version incompatibility error. I’ve reinstalled the pulumi node stuff via npm, and I’ve tried blowing away my plugins in ~/.pulumi to force a re-download. Still getting the error, any ideas?
Copy code
Found incompatible versions of @pulumi/pulumi. Differing major or minor versions are not supported.
   Version 1.13.1 referenced at node_modules/@pulumi/pulumi/package.json
   Version 1.10.1 referenced at node_modules/@pulumi/kubernetesx/node_modules/@pulumi/pulumi/package.json
I figured out the cause. I’m not sure where this dependency came from, but removing it cleared things up:
Copy code
+++ b/package.json
@@ -5,7 +5,6 @@
   },
   "dependencies": {
     "@pulumi/kubernetes": "^1.0.0",
-    "@pulumi/kubernetesx": "^0.1.1",
     "@pulumi/pulumi": "^2.0.0-beta.1"
   }
 }