https://pulumi.com logo
#general
Title
# general
a

adorable-musician-66353

04/07/2020, 12:24 PM
When I 'pulumi up' my Pulumi ts project I got the following warning:
Copy code
warning: resource plugin azure is expected to have version >=2.3.1, but has ; the wrong version may be on your path, or this may be a bug in the plugin
What to do to fix this?
c

colossal-room-15708

04/07/2020, 12:30 PM
did you run
npm install
? What does your `packages.json`look like?
a

adorable-musician-66353

04/07/2020, 12:35 PM
Copy code
{
  "name": "hello-az-fn",
  "devDependencies": {
    "@types/node": "^8.0.0"
  },
  "dependencies": {
    "@pulumi/pulumi": "^1.14.0",
    "@pulumi/azure": "^2.4.1"
  }
}
I did run it.
b

better-rainbow-14549

04/07/2020, 12:46 PM
i get the exact same thing but it hasn't caused any problems that i know of. i think the providers just don't report their version number correctly yet?
a

adorable-musician-66353

04/07/2020, 1:15 PM
Thank you. Will add an issue to the repo.
Found a similar existing issue for this problem https://github.com/pulumi/pulumi-azure/issues/506
👍 1
b

broad-dog-22463

04/07/2020, 1:51 PM
Hey all this was fixed in 2.4.1 of Pulumi-azure
👍 1
b

better-rainbow-14549

04/07/2020, 3:51 PM
FYI the same happens with azuread
Copy code
warning: resource plugin azuread is expected to have version >=1.8.0, but has ; the wrong version may be on your path, or this may be a bug in the plugin
b

broad-dog-22463

04/07/2020, 8:11 PM
Oh thanks for the information @better-rainbow-14549 - I’ll get that fixed up ASAP!