https://pulumi.com logo
#general
Title
# general
h

handsome-cat-98152

04/16/2020, 11:08 AM
@broad-dog-22463 Found a rather worrying bug: The output of pulumi up/preview tells me this:
Copy code
error: no resource plugin 'gcp-v1.4.5' found in the workspace or on your $PATH, install the plugin using `pulumi plugin install resource gcp v1.4.5`
Now, when I run this command I run into a different error:
Copy code
> pulumi plugin install resource gcp v1.4.5                                                                       ~/Graphmasters/pummeleinhorn/tests/basic_deployment(cloud-dns-records-108✗)@Nilss-MBP.fritz.box
[resource plugin gcp-1.4.5] installing
error: [resource plugin gcp-1.4.5] downloading from <https://api.pulumi.com/releases/plugins>: 404 HTTP error fetching plugin from <https://api.pulumi.com/releases/plugins/pulumi-resource-gcp-v1.4.5-darwin-amd64.tar.gz>
Is there a workaround? Greetings and have a nice day!
b

broad-dog-22463

04/16/2020, 11:14 AM
What version of the gcp provider are you using? We are at >2.0.0
s

stocky-island-3676

04/16/2020, 11:55 AM
@broad-dog-22463 I’ve tried it with the current
@pulumi/gcp: 2.13.0
version (checked in
package-lock.json
). But it’s an indirect dependency from our module. Here’s the longer whole output from CircleCI. It works locally without this error message.
b

broad-dog-22463

04/16/2020, 11:57 AM
That's a package from November 2019 - I have just ran the command
pulumi plugin install resource gcp v1.6.0
and was able to get the package
are you able to find out where in the package-lock file gcp 1.6.0 is?
s

stocky-island-3676

04/16/2020, 1:12 PM
@broad-dog-22463 There’s no
gcp 1.6.0
in the
package-lock.json
. I’ve searched for
1.6.0
and only found
Copy code
"@pulumi/kubernetes": {
                    "version": "1.6.0",
Yeah,
pulumi plugin install resource gcp v1.6.0
works here (in comparison to
v1.4.5
what Nils mentioned). Still, why do we need this? I mean @gentle-diamond-70147 recently mentioned that this shouldn’t be needed normally.