https://pulumi.com logo
#general
Title
# general
w

wonderful-dog-9045

05/05/2020, 4:30 PM
pulumi up
is getting stuck at the preview stage, even if the pulumi program is empty:
Copy code
$ pulumi up
Previewing update (dev):
     Type                 Name               Plan     
     pulumi:pulumi:Stack  empirica-base-dev           
 
System Messages
  ^C received; cancelling. If you would like to terminate immediately, press ^C again.
  ^C received; terminating
  ^C received; terminating
It won't even terminate with Ctrl+C. How do I troubleshoot this? I did try reinstalling pulumi. Also tried creating a new stack. Still fails.
b

billowy-army-68599

05/05/2020, 5:06 PM
@wonderful-dog-9045 which cloud provider are you using?
w

wonderful-dog-9045

05/06/2020, 8:56 AM
AWS
however it is the
pulumi-language-nodejs
process that locks up.
Looks like another annoyance with the customised runtime that the pulumi program runs in. When add a package dependency with file path:
file:../../
to the package.json, pulumi crashes (even though the module of that package is not imported in the index.js). Removing it again, fixes it (however there seems to be a cache issue too, in which it intermittently doesn't fix it). Running the
index.js
with node directly causes no problems either way.
I'm still not able to reproduce it in isolation. It does seem to matter what kind of package it refers to.
So now I have two identical projects, with a barebones package in root directory that only contains a package.json, with name, version and description and a nested subdirectory that contains an empty
index.js
as a pulumi program with a
devDependency
that points to
file:../..
, the package in the parent directory (yes, 2 levels up). One of these projects works and the other does not (it freezes). The one that doesn't work used to be more complex, before i started removing stuff from it to isolate the problem. I suspect its a cache issue, but I cannot figure out where it comes from.