https://pulumi.com logo
#general
Title
# general
s

silly-hairdresser-21136

05/10/2020, 9:49 AM
hi, I have a package that depends on @pulumi/aws 2.1.0 and @pulumi/random 2.1.0, and I'm trying to upgrade @pulumi/aws to 2.2.0 or 2.3.0 - when I do so, running
pulumi up
results in an error:
Copy code
[09:32:47]  pulumi:providers:random (default_2_2_0):
[09:32:47]   error: no resource plugin 'random-v2.2.0' found in the workspace or on your $PATH, install the plugin using `pulumi plugin install resource random v2.2.0`
it doesn't seem like upgrading @pulumi/aws should change the random plugin version, and running the install command from the error message results in:
Copy code
[resource plugin random-2.2.0] installing
error: [resource plugin random-2.2.0] downloading from <https://api.pulumi.com/releases/plugins>: 404 HTTP error fetching plugin from <https://api.pulumi.com/releases/plugins/pulumi-resource-random-v2.2.0-darwin-amd64.tar.gz>
anyone else seen this problem?
b

broad-dog-22463

05/10/2020, 11:11 AM
Hi @silly-hairdresser-21136
Sorry you are seeing this issue - there is indeed no such 2.2.0 plugin for random
I am trying to determine which plugin has that value right now
can you show me your package.json?
s

silly-hairdresser-21136

05/11/2020, 11:35 AM
hi @broad-dog-22463, sorry for the late reply, uploaded package.json and package-lock.json here: https://gist.github.com/bogsen/29633d88b080ab210c6dd05c630db7c6
found the issue - I was passing the same opts object to all child resources of my component, so all resources ended up using the provider version of the first resource