Hello seing a lot of this ```node-pre-gyp WARN Usi...
# general
Hello seing a lot of this
Copy code
node-pre-gyp WARN Using needle for node-pre-gyp https download 
node-pre-gyp WARN Pre-built binaries not installable for grpc@1.24.2 and node@12.16.3 (node-v72 ABI, glibc) (falling back to source compile with node-gyp) 
node-pre-gyp WARN Hit error bad download 
gyp WARN EACCES current user ("pulumi") does not have permission to access the dev dir "/root/.cache/node-gyp/12.16.3"
That increase the deployment time. I’m using the latest pulumi container image… any idea?
Hi @big-potato-91793, update to the Pulumi 2.0 packages.
The 2.0 packages use native `grpc-js`. I.e. no need to download
binaries anymore.
Ok good! So i think i found the one that give me this. Everything is 2.0 packages
The only one is pulumi-kubernetesx
Yeah. See issue #59 in `pulumi-kubernetesx`.
yeah I know. @broad-dog-22463 was supposed to look at it I think.
I believe Kubernetesx 0.1.3 has the pulumi 2.0 and pulumi-kuberntes 2.0 dependency
(or rather it uses latest which will pull those in)
don’t think so
forget about it 🤔 .. i saw
Copy code
"@pulumi/kubernetesx": {
            "version": "0.1.3",
            "resolved": "<https://registry.npmjs.org/@pulumi/kubernetesx/-/kubernetesx-0.1.3.tgz>",
            "integrity": "sha512-7x4O5WlxUYutGuOuiDJLPO/aKTh0yKQCSy2d/ypnpnV61HFq57hFvh2z5TZtOVZCOxzz4CVBWDsa6XXsfmApSQ==",
            "requires": {
                "@pulumi/kubernetes": "^2.2.0",
                "@pulumi/pulumi": "^2.2.1"
            "dependencies": {
                "@pulumi/kubernetes": {
                    "version": "2.2.0",
                    "resolved": "<https://registry.npmjs.org/@pulumi/kubernetes/-/kubernetes-2.2.0.tgz>",
                    "integrity": "sha512-1qbUD0kx5TWPykRd/WZw9g/RI2+JeatBSHALs58dGgclajLapjJiWrmbweQxEaDQ31O21RbixbDLcIWXPCenSg==",
                    "requires": {
                        "@pulumi/pulumi": "^2.0.0",
                        "@types/glob": "^5.0.35",
                        "@types/node-fetch": "^2.1.4",
                        "@types/tmp": "^0.0.33",
                        "glob": "^7.1.2",
                        "node-fetch": "^2.3.0",
                        "shell-quote": "^1.6.1",
                        "tmp": "^0.0.33"
                "@pulumi/pulumi": {
                    "version": "2.2.1",
                    "resolved": "<https://registry.npmjs.org/@pulumi/pulumi/-/pulumi-2.2.1.tgz>",
                    "integrity": "sha512-TuYyTqhjtbLNbXAEgBrkObfYX5fef5j2g39Qybg4BCccprmZ5Q/cqgnw0GYdqlyQaKWuuFosiOm8/6RqxmHGsw==",
                    "requires": {
                        "@grpc/grpc-js": "^0.6.15",
                        "@pulumi/query": "^0.3.0",
                        "google-protobuf": "^3.5.0",
                        "minimist": "^1.2.0",
                        "normalize-package-data": "^2.4.0",
                        "protobufjs": "^6.8.6",
                        "read-package-tree": "^5.3.1",
                        "require-from-string": "^2.0.1",
                        "semver": "^6.1.0",
                        "source-map-support": "^0.4.16",
                        "ts-node": "^7.0.1",
                        "typescript": "~3.7.3",
                        "upath": "^1.1.0"