Hey folks, hope this is the right avenue for repor...
# general
Hey folks, hope this is the right avenue for reporting what I think is a bug: In our eks node group settings, we had
(this is in python). Unfortunately, this is not the string you can use to ignore changes to the desired_size setting. You have to use ``ignore_changes=["scalingConfig.desiredSize"]`` instead. Which we learned when our node groups all got sized to one node each after applying an unrelated update.
Feel like this should be error-checked on preview, if possible. It's a very sharp edge on a cannonball that's pointed right at people's feet
I think that when you are referring to properties in pulumi you are referring to the JSON name of that property. The SDKs may have different naming conventions for argument properties because the languages themselves have different naming conventions, but they all converge on the resulting JSON that is serialized and sent to the provider - so this is the naming convention that you use when referring to property names via string constants. You can see that in your case here: https://github.com/pulumi/pulumi-aws/blob/d7d3d36b7324981b15c27397b80ee7159552de01/sdk/python/pulumi_aws/eks/_inputs.py#L505 You can see that while python convention may be snaked cased
the name of the property in JSON (the
attribute) is specified as
For instance I use the dotnet SDK which names properties on classes with pascal case. So if I were to provide
in your scenario it also wouldn't work for me, but here I can see that the name we converge on is
on the
attribute Of course I'm not saying whether or not that is desirable, you could open an issue if you want or maybe someone else can chime in - but AFAIK that is why it is the way it is so it probably isn't a bug
ah, github issues is probably the better venue to discuss this.
I think this is an OK place to bring it up! Sorry, I didn’t mean to imply it wasn't. I was just saying that it may be an sdk-dependent feature request as opposed to a bug report
oh, it's definitely specific to python
but I think everyone here was operating under the assumption that load-bearing strings like these would be checked for validity (:
anyway, reported https://github.com/pulumi/pulumi/issues/7081 - hope this makes sense
I'm pretty sure every SDK requires
, regardless of that SDK's naming convention - which is what I was getting at. So it is being validated, but all SDKs are being validated to
Oh yes - it would help if the provided names were validated at the time they were set. Yes, I agree, that would be nice.
🙌 1