https://pulumi.com logo
Title
c

creamy-raincoat-13266

07/15/2021, 11:53 PM
Hey all, I'm trying to integrate pulumi with circleci - however I'm running into this issue
#!/bin/bash -eo pipefail
if [ 16.0.2 == "latest" ]; then
  curl -L <https://get.pulumi.com/> | bash -s
else
  curl -L <https://get.pulumi.com/> | bash -s -- --version 16.0.2
fi
# Add to PATH
echo 'export PATH=${HOME}/.pulumi/bin:$PATH' >> $BASH_ENV
source $BASH_ENV

  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  6922  100  6922    0     0  87647      0 --:--:-- --:--:-- --:--:-- 88743
=== Installing Pulumi v16.0.2 ===
+ Downloading <https://get.pulumi.com/releases/sdk/pulumi-v16.0.2-linux-x64.tar.gz>...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
curl: (22) The requested URL returned error: 403 
error: failed to download <https://get.pulumi.com/releases/sdk/pulumi-v16.0.2-linux-x64.tar.gz>
r

red-match-15116

07/15/2021, 11:56 PM
pulumi is only on v3.7.0 so v16.0.2 doesn’t exist
c

creamy-raincoat-13266

07/16/2021, 12:08 AM
@red-match-15116 oh wow can't believe I missed something so obvious
I was just following this guide and they used v16 😅
r

red-match-15116

07/16/2021, 12:11 AM
That is super random! Thanks for pointing it out, we should figure out a way to get that fixed up.
👍 1