https://pulumi.com logo
#general
Title
# general
l

limited-rain-96205

09/06/2021, 9:16 PM
When using the Pulumi-Terraform bridge, is there a way to have it /not/ set a particular field of a resource? Like, not set the field at all, not pass anything to the Terraform provider.
I’m investigating an issue with the Proxmox provider (https://github.com/Matchlighter/pulumi-proxmoxve). There seems to be an upstream issue with the Terraform provider it’s using (https://github.com/Telmate/terraform-provider-proxmox), in which the QemuVM resource’s field
preprovision
has ConflictsWith set on several other fields, such as
os_type
.
When using Terraform, you can ignore this and simply not set
preprovision
at all, so there’s no conflict. But in the Pulumi provider, it seems to be setting this field regardless. Even not specifying
preprovision
at all, or setting it to false or undefined causes it to conflict with the other fields. This effectively means that in the Pulumi provider, you can’t set
osType
or
sshUser
at all.
So as a fix for the issue, the Pulumi-Terraform bridge should not send this field when it’s not set. Is that possible?
11 Views