:wave: hello! Has anyone been experiencing sporad...
# general
👋 hello! Has anyone been experiencing sporadic errors when doing
pulumi up
? The behavior I’m seeing: I run
pulumi up
. It takes an inordinate amount of time and hogs lots of resources. After ~10 mins, it fails with:
Copy code
  pulumi:pulumi:Stack (infra-dev):
    error: an unhandled error occurred: Program exited with non-zero exit code: -1
If I run
pulumi up
again, it runs quickly and with no errors. This cycle happens every time I make a change. Is this a known bug or has anyone else seen this? It’s making development impossibly slow. Thanks!
I haven't see that, sorry. Does it happen with another stack? If you create a new trivial project (maybe one bucket), does something similar happen? If you turn the log/debug info way up, do you get more hints from the output?
i’ll try these next time, thanks!
I have experienced something like that, in certain resources such as Azure Front Door (Classic), when there is an error (not in the code) that prevents the resource to be created e.g. permissions. My speculation is that Pulumi CLI retries to request and this delays the failure to appear. In other words, I tend to use it as an indication if the stack will succeed or fail.
I still see this, and it’s made pulumi unusable 😞 If I do
-v 3
, all new information I see is
Copy code
I1108 22:45:59.932048   72261 ignore.go:44] Explicitly ignoring and discarding error: rpc error: code = Canceled desc = grpc: the client connection is closing
I’ve also determined that this happens on my machine, but if I check out the code and run in another machine, it succeeds. Keep in mind I’m doing this inside a docker container, so the environments are exactly the same.