https://pulumi.com logo
#general
Title
# general
f

fresh-wire-95028

10/19/2021, 9:28 PM
I somehow got my stack into a really odd state. I tried manually deleting some resources, which put it into an even odder state. Now I'm getting these errors when trying to tear down my stack completely (
pulumi destroy
). Is there a way I can tell pulumi to destroy and ignore if the resource is not found?
Copy code
aws:ec2:SecurityGroupRule (api-cluster-toli-egress):
    error: deleting urn:pulumi:[secret]::accrue-api::awsx:x:ecs:Cluster$awsx:x:ec2:SecurityGroup$awsx:x:ec2:EgressSecurityGroupRule$aws:ec2/securityGroupRule:SecurityGroupRule::api-cluster-[secret]-egress: 1 error occurred:
        * couldn't find resource
r

red-match-15116

10/19/2021, 9:34 PM
Have you tried running
pulumi refresh
?
f

fresh-wire-95028

10/19/2021, 10:00 PM
ok. got it working. I had to manually track down all the resources and dependencies, delete them in the AWS console, and then run a combination of
pulumi refresh
,
pulumi up
,
pulumi config import/export
etc until things seemed back in sync. A command to just kill everything whether it exists or not would be super useful