https://pulumi.com logo
#general
Title
# general
b

broad-island-71889

12/20/2021, 9:35 PM
Hi guys, could you please help me to figure out what is going on with the Custom resource? Pulumi reports that the CR is updated, but it’s not. I’ve tried to upgrade the pulumi_kubernetes to 3.12.1, but it didn’t help. Would appreciate any directions for debugging this issue.
the issue is with
<http://elasticsearch.k8s.elastic.co/v1|elasticsearch.k8s.elastic.co/v1>
l

little-cartoon-10569

12/20/2021, 10:04 PM
Is the issue that the provider associated with a resource (cluster or whatever) hasn't updated, even though you've updated your packages.json (or whatever dependency tool you're using)?
If this is the problem, then you need to make a change to the resource. Pulumi avoids pushing to your cloud provider unless it needs to (a change is detected). And it won't change the state unless a cloud change is made.
Don't worry though: if this is what's happening for you, Pulumi will automatically make the change to each relevant resource, as it changes.
b

broad-island-71889

12/20/2021, 10:15 PM
Is the issue that the provider associated with a resource (cluster or whatever) hasn’t updated, even though you’ve updated your packages.json (or whatever dependency tool you’re using)?
Unfortunately, no. It’s not an issue with the provider, as I create the provider from kubeconfig. The problem is that pulumi detects the difference, then applies the changes, but nothing changes in the
spec
in pulumi interface and in kubernetes
even if I set
enable_replace_crd=True
hm, that’s interesting, the version of provider is
3.12.0
in the pulumi interface
l

little-cartoon-10569

12/20/2021, 10:49 PM
So you've got both problems 🙂
b

broad-island-71889

12/20/2021, 10:50 PM
how do I force the provider to be updated to the latest version ?
opts=(ResouceOptionsversion="3.12.1")
didn’t help
The problem is that I have only CR in the stack and nothing else
l

little-cartoon-10569

12/20/2021, 11:12 PM
Can you add a tag maybe? That would be seen as a change, so Pulumi would update the provider lib.
You could remove it again in another
up
.
b

broad-island-71889

01/14/2022, 8:00 PM
Faced same issue again,
up
doesn’t change much. Last time I had to delete and create a provider
can it be because I’m on pulumi 3.14.0 ?
l

little-cartoon-10569

01/16/2022, 8:41 PM
No, Pulumi version isn't relevant, in my experience. This has happened to me for all versions of Pulumi, but it always resolves itself. Are you maintaining your versions and running
up
frequently? It's a good idea to deploy frequently, so that the changes are smaller.
b

broad-island-71889

01/18/2022, 4:05 PM
yes, tried with latest pulumi version, doesn’t work either. I’ve created a bug in Github for this issue, not completely sure how to reproduce it, as it work in some cases, but not others.
😕 1