Hello! I'm wondering what in the pulumi cli is cau...
# general
Hello! I'm wondering what in the pulumi cli is causing the output to not show parent/child heirarchy when running within a child process (where in this case the parent is a Nx executor)? I'm imagining pulumi is detecting something about the env and flattening output.
--color always
works to enable colour output but heirarchy is still not there.
@magnificent-lifeguard-15082 are you parenting resources?
it's a manual process
using automation API?
Just CLI right now, would like to create a pulumi executor for Nx but time permitted. If I run pulumi directly from my terminal I see the expected output but when run from a nx task it is clearly using a different formatter. Ie.
Copy code
Type                                       Name                    Plan       Info
 +   pulumi:pulumi:Stack                        platform-preview        create..   warning: resource plugin aws is expected to hav
 +   ├─ awsx:x:ec2:SecurityGroup                service                 create
Copy code
+  pulumi:pulumi:Stack platform-preview create 
 +  pulumi:pulumi:Stack platform-preview create API key does not start with "SG.".
 +  pulumi:pulumi:Stack platform-preview create 2 db service
I guess because in the former it can update previous output otherwise it defaults to streaming.
Ideally though it would just buffer and output the hierarchal output once it's done at the end as it's super useful compared to a flat list
oh yeah, this is by design at the moment. if you need the fancy output you'll need to open an issue.
Put it as a bug but happy to reclass as a refinement