https://pulumi.com logo
#python
Title
# python
e

echoing-dawn-86996

08/19/2020, 4:09 PM
Hey guys! I'm trying to upgrade from '2.2.1' to '2.8.2' and I'm getting import errors:
Copy code
from pulumi.resource import ComponentResource, ResourceOptions, export
from pulumi_gcp import service_account, projects
This is the error:
Copy code
File "./components/service_accounts_binding.py", line 2, in <module>
    from pulumi_gcp import service_account, projects
ImportError: cannot import name 'service_account' from 'pulumi_gcp' (/usr/local/lib/python3.7/site-packages/pulumi_gcp/__init__.py)
My requirements.txt:
Copy code
pulumi>=2.0.0,<3.0.0
pulumi-gcp>=3.0.0,<4.0.0