Hello. I've tried a lot of searches and cannot fin...
# python
Hello. I've tried a lot of searches and cannot find why this is failing. Anyone have ideas? Code: sample_image = docker.Image(     "sample-dockerimage",     image_name=sample_ecr_repo.repository_url,     build="../projects/hello_world",     skip_push=False,     registry=sample_registry, ) Failure: File "C:\Program Files\Python38\lib\subprocess.py", line 1307, in _execute_child hp, ht, pid, tid = _winapi.CreateProcess(executable, args, FileNotFoundError: [WinError 2] The system cannot find the file specified error: an unhandled error occurred: Program exited with non-zero exit code: 1
I would think build would equal docker.build() then supply the context, dockerfile etc. what path is it failing on, it appears to be the build.
I cannot determine that with the output I'm getting. If I run the docker build command that pulumi issues, everything appears to work fine.
When executing pulumi up or preview, this command is executed by pulumi just before it errors with the output I mentioned. This same command runs fine if issued in the command window. Executing 'docker build -t 123456789012-dkr.ecr.us-east-2.amazonaws.com/sample-repository-12345678 ../project/hello_world'