I have a colleague who is experiencing a weird iss...
# python
s
I have a colleague who is experiencing a weird issue with their local Pulumi dev env. when they run
pulumi up
on a stack that references other stacks, the stack reference is empty. in this case, it’s a reference to an AWS region. additionally, when they run
pulumi config
the output is empty, where as when I run it on the same stack I do see the expected config output
@orange-agency-91666 can you paste the output?
b
are you using an S3 bucket as your backend?
o
Copy code
Type                             Name                          Plan       Info
 +   pulumi:pulumi:Stack              vpc-david-test.sbx.us-east-1  create     1 error
     └─ pulumi:pulumi:StackReference  hatch-infra/region/None                  1 error

Diagnostics:
  pulumi:pulumi:Stack (vpc-david-test.sbx.us-east-1):
    error: preview failed

  pulumi:pulumi:StackReference (hatch-infra/region/None):
    error: Preview failed: unknown stack "hatch-infra/region/None"
this is the output i get
s
@billowy-army-68599 nah we’re using the pulumi cloud
David can list stacks successfully with
pulumi stack ls
b
can you file a ticket with support@pulumi.com for this? we should probably get on a call and take a look
👍 2
just to be clear we have someone monitoring that channel so someone should pick it up quickly, sorry for the redirect!
s
np, thanks!
update: the stack config file name was incorrect. easy fix! with that said I wonder if there’s some way to verify the file exists when running Pulumi?
117 Views