Hello, what could be preventing python from findin...
# python
Hello, what could be preventing python from finding the pulumi_aws module? If I try to run any sort of pulumi command I face a:
ModuleNotFoundError: No module named 'pulumi_aws'
But browsing the packages of the enviroment it seems to be in order (I make sure it's the default env when trying to deploy, I have tried recreating the env and installing the packages again as well)
Hi Claudia. What
pulumi about
says ?
I ran into this when the requirements.txt didn’t contain the proper packages, but looks like you verified that it's already there and in the venv?
Hello, it turns out that I was using Conda to manage my environments but pulumi enforces venv, so I was looking at the wrong list of installed packages, I gotta say this is is the first time I run into this conflict, can I configure pulumi to recognize conda as the environment manager?
Yeah I ran into the same thing haha, requirements.txt is key. There was definitely an article explaining how to change it from defaulting to venv, however ultimately once I figured out requirements.txt was all I needed to update I saw the benefit and kept it.
You can use other Python package managers with Pulumi (I use Poetry and so can do
poetry run pulumi up