https://pulumi.com logo
#install
Title
# install
e

elegant-twilight-2745

12/10/2019, 1:24 PM
Pulumi up: error Failed to locate python3? But I just created a virtualenv from it?
w

white-balloon-205

12/10/2019, 1:37 PM
I believe some Windows installations of Python 3.6 do not install a
python3
binary. If you do not have one, you’ll need to use the workaround in https://github.com/pulumi/pulumi/issues/3398#issuecomment-546138407 until that issue is fixed.
e

elegant-twilight-2745

12/10/2019, 4:46 PM
Hi Luke managed to get closer to pulumi up... now using python 3.7.5 and copying python.exe to python3.exe as you suggested there. Now only have this aws-py-resources error No module named pulumi
w

white-balloon-205

12/10/2019, 4:48 PM
Sounds like you didn’t install pip requirements / did you actually successfully run all the steps in https://github.com/pulumi/examples/tree/master/aws-py-resources#aws-resources.
e

elegant-twilight-2745

12/10/2019, 4:50 PM
Sorry that was previous error
It is Authenticate against AD?
Is this because I am using a normal personal account but in corporate ENV?
While in aws-py-resources: 1. Pulumi stack init dev in aws-py-resource didn’t generate new resources (is that to be expected?) 2. Pulumi config set aws:region eu-west-2 3. Opened project in Pycharm and created virtualenv 4. Then inside virtualenv pip install -r requirements.txt 5. Pulumi up And that last response gave You must be authenticated to access this URL
Firewall issue?
If so then request internal corporate help to whitelist?
w

white-balloon-205

12/10/2019, 5:07 PM
Authenticate user against AAD
Honestly no idea - and would need more context on what you are doing. This doesn’t sound related to Pulumi - it sounds like something to do with lockdown in your corporate environment. I might be able to help troubleshoot if you could be very specific on the steps you took and the results you saw.
You must be authenticated to access the URL
Again - no idea the context of that message. What exact action did you take and what exact output did you get? That error message is not something that comes from Pulumi - but I don’t know what exactly you are doing to get it so hard to know what to suggest.
e

elegant-twilight-2745

12/10/2019, 5:10 PM
Labeled from steps 1 to 5 above Luke
“Proxy received an invalid response” and then the page above
w

white-balloon-205

12/10/2019, 6:17 PM
I apologize - but I really can’t follow the steps you are sharing here - and would need the exact output to be able to help - not just a couple words from the output. What is the full output of running
pulumi up
and ideally also
pulumi up —logtostderr -v=9
.
e

elegant-twilight-2745

12/11/2019, 12:10 PM
Manually downloaded 1.6.1 and updated path in Win 10 but still saying version 1.6.0? Do I need to restart Win machine?
w

white-balloon-205

12/11/2019, 4:07 PM
No - you should not need to download. Sounds like your path still includes the older installation first?