https://pulumi.com logo
#automation-api
Title
# automation-api
b

bored-oyster-3147

05/12/2021, 7:11 PM
Hey everyone - finally got to the point internally that we are now testing the Automation API portion of our in-house CD API. Having an issue that I thought had already been addressed but may be misremembering. Consistently getting the
error: PULUMI_ACCESS_TOKEN must be set for login during non-interactive CLI sessions
message. Trying to use a self-managed backend so I don't think I should be hitting this, or may be missing something. I currently have the backend set both in the project settings and in
PULUM_BACKEND_URL
I see a thread here https://pulumi-community.slack.com/archives/C019YSXN04B/p1619024754146000 about it but it looks like Ringo was using the pulumi service backend so he was able to just provide an access token
Any insight on this that I'm missing?
f

faint-table-42725

05/13/2021, 1:28 PM
I don’t think so? I haven’t tried this in .NET, but in NodeJS, for example, I had no issues setting the backend via project settings (and don’t do anything with the env var)
l

lemon-agent-27707

05/13/2021, 3:10 PM
Could it be that your backend URL is malformed? That could force the CLI to try and log you in to the service: https://github.com/pulumi/pulumi/blob/73a66f48ead301bacf1d7d2833c016cf803b57c1/pkg/cmd/pulumi/login.go#L128
b

bored-oyster-3147

05/13/2021, 7:25 PM
I believe that was the issue. I was using local filestate for testing purposes and my path was
file://{path}
but when you use
Path.Combine(...)
in dotnet it uses back slashes instead of forward slashes, so pulumi wasn't liking that. Thanks guys!
partypus 8bit 1
b

bored-activity-40468

05/15/2021, 12:03 AM
@faint-table-42725 I've verified that it works in .NET.
🙏 1
👍 1
15 Views