https://pulumi.com logo
#automation-api
Title
# automation-api
p

proud-pizza-80589

11/03/2021, 7:38 AM
anyone ever see
error: installing [resource plugin kubernetes-3.6.3] from : untarring file /Users/roderik/.pulumi/plugins/resource-kubernetes-v3.6.3/pulumi-resource-kubernetes: stream error: stream ID 1; PROTOCOL_ERROR
Got my new M1 Max and use node 16 with the automation api and this starts happening, doesn’t do this on Intel or in amd64 docker containers. Running regular pulumi programs works just fine.
it appears my colleague @famous-train-16653 had the same a while back https://pulumi-community.slack.com/archives/C84L4E3N1/p1629445533462600 But he is on Intel.
His workaround worked
but seems weird that the plugin installation in the automation api fails on installing.
l

lemon-agent-27707

11/03/2021, 8:55 PM
but seems weird that the plugin installation in the automation api fails on installing.
Agree that is unexpected. Does this repro consistently? You are using inline programs, right?