https://pulumi.com logo
#golang
Title
# golang
g

gifted-city-99717

06/12/2020, 3:41 AM
My integration test is timing out. Is there a way to override the test timeout? I have a 30m timeout set on the resource, but it doesn’t seem to propagate up
Copy code
[ oyments/ci-telemetry/escluster ]  +  pulumi:pulumi:Stack escluster-p-it-loptaploca-escluster-cd98c21a creating
[ oyments/ci-telemetry/escluster ]  +  citelemetry:elasticsearch:ESClusterComponent insights-ci-es-dev creating
[ oyments/ci-telemetry/escluster ]  +  aws:ec2:SecurityGroup insights-ci-es-dev-sg creating
[ oyments/ci-telemetry/escluster ]  +  aws:iam:ServiceLinkedRole insights-ci-es-dev-linked-role creating
[ oyments/ci-telemetry/escluster ]  +  aws:iam:ServiceLinkedRole insights-ci-es-dev-linked-role created
[ oyments/ci-telemetry/escluster ]  +  aws:ec2:SecurityGroup insights-ci-es-dev-sg created
[ oyments/ci-telemetry/escluster ]  +  aws:elasticsearch:Domain insights-ci-es-dev creating
[ oyments/ci-telemetry/escluster ] @ Updating....[ oyments/ci-telemetry/escluster ] Still running command '/usr/local/bin/pulumi up --non-interactive --yes --skip-preview --event-log /var/folders/30/1ks5_94n54x29jjdkhvj974m0000gn/T/p-it-loptaploca-escluster-cd98c21a-events.json' (/Users/jws/code/gocode/src/stackName-1591932181711912000)...
[ oyments/ci-telemetry/escluster ] .[ oyments/ci-telemetry/escluster ] .[ oyments/ci-telemetry/escluster ] .[ oyments/ci-telemetry/escluster ] .[ oyments/ci-telemetry/escluster ] .[ oyments/ci-telemetry/escluster ] .[ oyments/ci-telemetry/escluster ] Still running command '/usr/local/bin/pulumi up --non-interactive --yes --skip-preview --event-log /var/folders/30/1ks5_94n54x29jjdkhvj974m0000gn/T/p-it-loptaploca-escluster-cd98c21a-events.json' (/Users/jws/code/gocode/src/stackName-1591932181711912000)...
[ oyments/ci-telemetry/escluster ] .[ oyments/ci-telemetry/escluster ] .[ oyments/ci-telemetry/escluster ] .[ oyments/ci-telemetry/escluster ] .[ oyments/ci-telemetry/escluster ] .[ oyments/ci-telemetry/escluster ] .coverage: 0.0% of statements
panic: test timed out after 10m0s

goroutine 31 [running]:
testing.(*M).startAlarm.func1()
	/usr/local/Cellar/go/1.14.3/libexec/src/testing/testing.go:1459 +0xdf
created by time.goFunc
	/usr/local/Cellar/go/1.14.3/libexec/src/time/sleep.go:168 +0x44
anyone figure out how to override the timeout in an integration test?
l

lemon-agent-27707

06/12/2020, 10:34 PM
This is the default timeout for the go tool test runner, nothing pulumi specific. You should be able to pass the
-timeout
flag on the command lint to set it to something longer: https://golang.org/cmd/go/#hdr-Testing_flags
g

gifted-city-99717

06/16/2020, 9:18 PM
ok. thanks. I’ll take a look. I didn’t see a way to pass params from the integration tests, but will look again
l

lemon-agent-27707

06/16/2020, 10:07 PM
Just to be clear, the flag is for the go language test runner. You would pass it when invoking your tests from the CLI:
Copy code
$ go test -run TestPulumiIntegration -timeout 30m
g

gifted-city-99717

06/17/2020, 6:19 PM
👍 awesome. thanks
17 Views