https://pulumi.com logo
#golang
Title
# golang
m

microscopic-agent-70604

03/23/2021, 11:50 AM
Hi. I've updated pulumi-aws go module to the latest version and got an error and I do not understand where to dig. As I understood, terraform aws provider was updated and now we can use some additional parameters in the provider, but we do not create AWS provider explicitly in the code. It is created automatically and is used as a default.
Copy code
error: program failed: 1 error occurred:
        * rpc error: code = Unknown desc = invocation of aws:ec2/getVpc:getVpc returned an error: could not validate provider configuration: 9 errors occurred:
        * Invalid or unknown key
        * Invalid or unknown key
        * Invalid or unknown key
        * Invalid or unknown key
        * Invalid or unknown key
        * Invalid or unknown key
        * Invalid or unknown key
        * Invalid or unknown key
        * Invalid or unknown key
    exit status 1
Could anybody please give a hint where to go?
1
👍 1
g

gentle-diamond-70147

03/23/2021, 4:08 PM
Do you have custom
aws:
configuration values in your stack configuration? I believe this can occur when you've set "custom" configuration values under the
aws:
namespace which is reserved for the default provider itself.
👍 1
In other words, if you were to do
pulumi set aws:myCustomConfig asdf
, you would get that error message because
myCustomConfig
is not a valid configuration property on the
aws.Provider
.
👍 1
m

microscopic-agent-70604

03/23/2021, 4:29 PM
Yes. We did it like this. We have aws: namespace and put there every our configuration parameter. Do you have a link or some document where it's written that we can't do it or some architecture link?
g

gentle-diamond-70147

03/23/2021, 4:42 PM
Our general config documentation is at https://www.pulumi.com/docs/intro/concepts/config/#configuration-keys, but I'm not sure if we explicitly explain it in those terms.
👍 1
For your own custom configuration you can just use
pulumi config set myCustomConfig asdf
without the
aws:
prefix and use the configuration values that way.
👍 1
5 Views