https://pulumi.com logo
#golang
Title
# golang
r

ripe-shampoo-80285

08/23/2021, 1:23 PM
Downgrade github.com/pulumi/pulumi-kubernetes/sdk/v3 from v3.6.2 to v3.5.1 fixed the issue!!!
Could this be a code generation issue in the latest k8s provider module?
g

green-motorcycle-58080

08/23/2021, 4:05 PM
It looked like they moved the providers package up a level to
kubernetes
package
i.e. use
<http://github.com/pulumi/pulumi-kubernetes/sdk/v3/go/kubernetes|github.com/pulumi/pulumi-kubernetes/sdk/v3/go/kubernetes>
to create a
NewProvider
instead of
providers.NewProvider
@ripe-shampoo-80285 does that help?
r

ripe-shampoo-80285

08/23/2021, 4:18 PM
Thanks @green-motorcycle-58080! That worked!
g

green-motorcycle-58080

08/23/2021, 4:19 PM
np, it caught me off guard too, should have been documented tbh
Looks like it was moved in 3.6.0
b

billowy-army-68599

08/23/2021, 4:49 PM
@ripe-shampoo-80285 can you open a github issue for this? in github.com/pulumi/pulumi-kubernetes
r

ripe-shampoo-80285

08/23/2021, 5:36 PM
4 Views