https://pulumi.com logo
#dotnet
Title
# dotnet
l

little-kangaroo-50941

02/27/2020, 10:17 PM
Ciao! Is it possible to deploy an Azure App Service with the last (3.1 would be ok) .Net Core runtime? I can’t see “runtime” option in the object model…and also I cannot see it in Terraform
t

tall-librarian-49374

02/28/2020, 7:19 AM
l

little-kangaroo-50941

02/28/2020, 9:44 AM
Top! Thank you another time! It’s another topic but I noticed that if you try to set a config variable that starts with $ (like $xxxx.01) what is saved is just “.01”. Same thing if I wrap the value inside “”. Using single quotes ‘’ it works good. Is it the aspected behavior?
Mikhail I just tried with
Copy code
LinuxFxVersion = "DOTNETCORE|3.1",
but it doesn’t work, it says that the value is not valid
exporting the ARM template I cannot see something related to the runtime stack
Maybe is something related to the appservice tier, I tried with a simple Shared D1. For example starting from the Azure portal is still not possibile tu setup an app with NETCORE 3.1 in Windows…but this is just a portal issue because the runtime is correcly isntalled
a

adventurous-garage-59192

03/03/2020, 12:26 AM
I haven't really found that runtime setting to be useful. The app service has everything installed anyways and changing that doesn't appear to do anything (at least in my experience)
t

tall-librarian-49374

03/03/2020, 7:38 AM
yeah I have the same experience @adventurous-garage-59192