10/22/2019, 1:28 PM
Hello ! I recently upgraded my node version from 10.13 to 12.11. Under this version I have an issue with @pulumi/aws. Any code inside someOutput.apply() never executes during preview (tried aws.s3 and aws.lambda). I tried a few versions of this library, from the 1.4.0 to 1.7.0, with the same result. I'll paste repro steps in the thread.
Only 1 bucket is shown in preview : bk1, and log "DBG" is not present in "Diagnostic"
Type Name Plan + pulumi😛ulumi:Stack test-test create + └─ aws😒3:Bucket bk1 create
node --version : v12.11.0
Outputs: + bucket1: output<string> + bucket2: output<string>
At execution, the 2 buckets are created successfully and the output is correct : + ├─ aws😒3:Bucket debug-bucket created + └─ aws😒3:Bucket debug-bucket-b7b20b4-copy created


10/22/2019, 5:08 PM
Which part of this looked wrong to you? The
callbacks will not be called until the resources are created (or more precisely, until the
is "known". So the above looks to be correct if I'm reading it all right - and should be the same regardless of Node version.