https://pulumi.com logo
#typescript
Title
# typescript
b

breezy-cricket-40277

04/01/2020, 1:58 PM
Warning:
Copy code
resource plugin azure is expected to have version >=2.3.1, but has ; the wrong version may be on your path, or this may be a bug in the plugin
Is there any required configuration missing?
Already tried to remove and install the plugin again, but no effect.
m

miniature-arm-21874

04/01/2020, 2:04 PM
https://www.npmjs.com/package/@pulumi/azure presumably you have this installed and it's = version 2.3.1 ?
ah just saw your above message, apologies
b

breezy-cricket-40277

04/01/2020, 2:19 PM
Copy code
{
  "name": "test",
  "dependencies": {
    "@pulumi/azure": "^2.3.1",
    "@pulumi/pulumi": "^1.13.0",
    "@pulumi/random": "^1.7.0"
  },
  "devDependencies": {
    "@types/node": "^13.9.8"
  }
}
👍 1
even uninstalling every package, removing
node_modules
and
package-lock.json
and running `npm install`in every package results in the error.
m

miniature-arm-21874

04/01/2020, 2:57 PM
and your pulumi cli is up to date?
b

breezy-cricket-40277

04/01/2020, 2:57 PM
Yep. pulumi 1.13.1
Not sure what’s missing, have you guys experienced a similar problem?
I’ve checked and there’s already a Issue for this problem, just wanted to point that out in here in case anyone is reading this: https://github.com/pulumi/pulumi-azure/issues/506