BTW, there is a discrepancy between this part of t...
# typescript
BTW, there is a discrepancy between this part of the README of the core Pulumi SDK:
This SDK uses Node.js and we support the Active LTS and Current releases, as defined by this table.
and the `package.json`:
Copy code
"engines": {
    "node": ">=8.13.0 || >=10.10.0"
Vrsion 8.13+ should be removed. Your
says it transpiles to
, which 8.13 definitely does not support everything off. See
Yes - we will remove this. We recently removed testing support in our test matrix for Node 8 as well - and updated most of our docs to be clearer about not supporting Node 8.
I also found traces of
snippets in tf-bridge code in some providers. It points to a JS dependency of
which should also be bumped to
@white-balloon-205 the changelog for 2.0.0 still mentions Node 8.13.0 is supported. I guess that is wrong, no?
Thanks for pointing that out - that entry is immaculate now (it was related to a change in the 2.0 branch several months ago that has been superseded). We will fix it.
👍🏼 1