https://pulumi.com logo
#typescript
Title
# typescript
l

limited-rainbow-51650

04/16/2020, 2:26 PM
BTW, there is a discrepancy between this part of the README of the core Pulumi SDK:
This SDK uses Node.js and we support the Active LTS and Current releases, as defined by this table.
and the `package.json`:
Copy code
"engines": {
    "node": ">=8.13.0 || >=10.10.0"
}
Vrsion 8.13+ should be removed. Your
tsconfig.json
says it transpiles to
es2016
, which 8.13 definitely does not support everything off. See https://node.green/
w

white-balloon-205

04/17/2020, 3:18 AM
Yes - we will remove this. We recently removed testing support in our test matrix for Node 8 as well - and updated most of our docs to be clearer about not supporting Node 8.
l

limited-rainbow-51650

04/17/2020, 6:35 AM
I also found traces of
package.json
snippets in tf-bridge code in some providers. It points to a JS dependency of
@types/node
which should also be bumped to
>=10
then.
@white-balloon-205 the changelog for 2.0.0 still mentions Node 8.13.0 is supported. I guess that is wrong, no? https://github.com/pulumi/pulumi/blob/master/CHANGELOG.md#200-2020-04-16
w

white-balloon-205

04/21/2020, 1:03 PM
Thanks for pointing that out - that entry is immaculate now (it was related to a change in the 2.0 branch several months ago that has been superseded). We will fix it.
👍🏼 1