https://pulumi.com logo
#typescript
Title
# typescript
p

purple-beach-36424

08/16/2021, 7:06 PM
Hi I usually don’t get this error in any of our pulumi projects but here it is:
Copy code
error: 1 error occurred:
    	* error configuring Terraform AWS Provider: no valid credential sources for Terraform AWS Provider found.
    
    Please see <https://registry.terraform.io/providers/hashicorp/aws>
    for more information about providing credentials.
    
    Error: NoCredentialProviders: no valid providers in chain. Deprecated.
    	For verbose messaging see aws.Config.CredentialsChainVerboseErrors
Some notes: 1. The
NoCredentialProviders
part is impossible since the state is pushed into an s3 bucket in the same account and everything works fine (was able to run
pulumi login
&
pulumi stack select
prior to the
pulumi preview
I’m currently trying to run) 2. The credentials are provided by a role annotation on a k8s runner who has access to the aws account 3. Tried downgrading AND upgrading libs (
@pulumi/pulumi
,
@pulumi/aws
&
@pulumi/awsx
) because of known past issues with aws providers 4. I tried configuring the provider the most explicit way possible and it still doesn’t work
Copy code
new aws.Provider(name, {
    skipCredentialsValidation: false,
    skipMetadataApiCheck: false,
    skipGetEc2Platforms: false,
    skipRequestingAccountId: false,
    skipRegionValidation: false,
    region: this.region,
});
I don’t know where to look next to understand why this doesn’t work as expected. Thank you in advance for any feedback.
l

little-cartoon-10569

08/16/2021, 9:23 PM
Have you enabled verbose messaging, as suggested in the error? I see reported instances of this where the problem is local and temporary. Does this issue give more insight? https://github.com/aws/aws-sdk-go/issues/2914
4 Views