https://pulumi.com logo
#typescript
Title
# typescript
r

refined-terabyte-65361

11/18/2021, 12:35 AM
Hello i am trying to use PodDisruptionBudget https://www.pulumi.com/registry/packages/kubernetes/api-docs/policy/v1beta1/poddisruptionbudget/#create but it shows that 'name' is deprecated. when i try to use it
Copy code
const pdb = new k8s.policy.v1beta1.PodDisruptionBudget(
name: "pdb"
  )
b

billowy-army-68599

11/18/2021, 12:49 AM
it's deprecated by the k8s server, do:
Copy code
const pdb = new k8s.policy.v1.PodDisruptionBudget
r

refined-terabyte-65361

11/18/2021, 1:47 AM
gives same error
Copy code
const pdb = new k8s.policy.v1.PodDisruptionBudget(
  name: "pdb"
    )
p

proud-pizza-80589

11/18/2021, 2:32 PM
Copy code
k8s.policy.v1.PodDisruptionBudget("pbd")
there is no object between the ()
so key value will not work