https://pulumi.com logo
#contribex
Title
# contribex
a

acoustic-tiger-77630

05/31/2022, 4:17 AM
Hey Guys. I followed along the video from Paul and David to build a Pulumi provider Bridged to a Terraform provider I’ve built here Everything seems to be working fine until when I run pulumi up to test a small nodejs project. I keep on receiving the following message, but I can’t figure it out how to fix that. If I run the project empty, it works without any problem. Any idea how to fix/address this problem? Broken
Copy code
$ pulumi up                                                                                                                                                        
Previewing update (dev)
View Live: <https://app.pulumi.com/willguibr/zpa_segment_group/dev/previews/57a0ebdd-d885-46a6-b468-420e4ae1c381>
     Type                          Name                                           Plan       Info
     pulumi:pulumi:Stack           zpa_segment_group-dev
 +   ├─ random:index:RandomPet     random-description                             create
 +   ├─ random:index:RandomPet     random-name                                    create
 +   ├─ random:index:RandomString  random                                         create
     └─ pulumi:providers:zpa       default_0_0_1_alpha_1653938881_7168adbb_dirty             1 error
Diagnostics:
  pulumi:providers:zpa (default_0_0_1_alpha_1653938881_7168adbb_dirty):
    error: no resource plugin 'pulumi-resource-zpa' found in the workspace at version v0.0.1-alpha.1653938881+7168adbb.dirty or on your $PATH, install the plugin using `pulumi plugin install resource zpa v0.0.1-alpha.1653938881+7168adbb.dirty`
Empty Project
Copy code
$ pulumi up                                                                                                                                                       
Previewing update (dev)
View Live: <https://app.pulumi.com/willguibr/zpa_segment_group/dev/previews/086b4344-d8ac-44b7-a4b8-cca68221b744>
     Type                 Name                   Plan
 +   pulumi:pulumi:Stack  zpa_segment_group-dev  create
Resources:
    + 1 to create
Do you want to perform this update? yes
Updating (dev)
View Live: <https://app.pulumi.com/willguibr/zpa_segment_group/dev/updates/1>
     Type                 Name                   Status
 +   pulumi:pulumi:Stack  zpa_segment_group-dev  created
Resources:
    + 1 created
Duration: 1s
Found the answer after some dig in through the Internet. This error is caused by lack of GOPATH and PATH being set or being set incorrectly. I fixed by adding the following to my
~/.zshrc
export PATH=$PATH:$(go env GOPATH)/bin
export GOPATH=$(go env GOPATH)
The bridge to TF worked like a charm after that. Now I am just jumping through some hoops to get it working in GO and Python. Fun challenge 😀
👍 1
4 Views